Author Topic: Glow plug puzzle  (Read 1717 times)

Offline RayW

  • Full Member
  • ****
  • Posts: 419
Glow plug puzzle
« on: June 06, 2017, 03:32:34 PM »
Can someone please explain the following to me:

With the glow plug on my Otto glowing, if I disconnect either the positive or negative glow plug driver lead from the 12 volt battery then re-connect it, the plug does not light up again. If, on the other hand, with the driver leads connected to the battery, I disconnect either the positive lead from the plug, or the earth (ground) lead from the body of the engine, then reconnect, the plug starts to glow again.
I am sure there is a logical explanation, but I just can't figure out what it is at the moment. All suggestions gratefully received!
Ray

Offline Admiral_dk

  • Full Member
  • ****
  • Posts: 1357
  • Søften - Denmark
Re: Glow plug puzzle
« Reply #1 on: June 06, 2017, 10:01:47 PM »
It must be the electronic part of the driver, that shuts down when you remove a lead and because it is still connected to the power it stays that way - and when you remove the power to the unit and reconnects it, it starts from scratch again (a bit like resetting the computer).

I believe the fact that it stays off even when connected to the power supply, is done to protect the battery from being discarded (destroying it)  :zap:

Best wishes

Per

Offline RayW

  • Full Member
  • ****
  • Posts: 419
Re: Glow plug puzzle
« Reply #2 on: June 07, 2017, 07:08:03 PM »
Thanks Per. The driver seems to be working again correctly today. I am not sure why it was doing strange things yesterday.

Ray
Ray

Offline Noitoen

  • Full Member
  • ****
  • Posts: 103
  • Setúbal - Portugal
Re: Glow plug puzzle
« Reply #3 on: June 07, 2017, 09:12:22 PM »
Low battery cut out? Check out the voltage.