Author Topic: Rider Ericsson will not run - HELP!!!  (Read 9351 times)

Offline fumopuc

  • Full Member
  • ****
  • Posts: 2397
  • Munich, Germany, EU
Re: Rider Ericsson will not run - HELP!!!
« Reply #45 on: September 12, 2014, 05:59:04 AM »
 Hi Stan, congratulations. Good to see that you have been sucessfull at the end and the beast is alive now. Enjoy your malt. 
Kind Regards
Achim

Offline Roger B

  • Global Moderator
  • Full Member
  • *****
  • Posts: 4014
  • Switzerland
Re: Rider Ericsson will not run - HELP!!!
« Reply #46 on: September 12, 2014, 07:23:28 AM »
Congratulations  :ThumbsUp:  :ThumbsUp: Glad that you got it running  :)
Best regards

Roger

Online Jo

  • Administrator
  • Full Member
  • *****
  • Posts: 12698
  • Hampshire, england.
Re: Rider Ericsson will not run - HELP!!!
« Reply #47 on: September 12, 2014, 07:34:21 AM »
 :whoohoo:

Nice to see it running.

Jo
Usus est optimum magister

Offline Ian S C

  • Full Member
  • ****
  • Posts: 1065
  • Stirling Engine Maker Darfield Canterbury N Z
Re: Rider Ericsson will not run - HELP!!!
« Reply #48 on: September 12, 2014, 12:32:10 PM »
Congratulations,  they all seem to go eventually, some times you have to threaten them, and cause the air to become a bit blue.  And some times I'v ended up with a sore wrist flicking the flywheel.
     This engine is my second one, and is based on one of James G. Rizzo's engines "Dyna" from his book "The Stirling Engine Manual".  The bush in the gland through the piston is made of carbon impregnated Teflon. After building the motor I ran it for 1000 hours (can't remember how much LPG I used)  the crankshaft was warn, as was the big ends,  so I made new parts, cutting all the metal requiring a hacksaw with the little power hacksaw on the motor.  I then started to put it all together again, and when I tried to put the rod through the piston, it wouldn't go,  it had been di-assembled for about a fortnight. It had got oil on it, and swelled, but to me it was sort of funny, the bush did 1000 hrs, and then it was too tight!  (built in 1992)     Ian S C

Offline ShopShoe

  • Full Member
  • ****
  • Posts: 321
  • Central Iowa, Central USA
Re: Rider Ericsson will not run - HELP!!!
« Reply #49 on: September 12, 2014, 02:01:47 PM »
I've been following this. I knew it would run some day. Congratulations.


--ShopShoe

fcheslop

  • Guest
Re: Rider Ericsson will not run - HELP!!!
« Reply #50 on: September 12, 2014, 09:29:48 PM »
Congratulations on a runner :praise2: :praise2: :praise2:
cheers :DrinkPint: