Author Topic: Rider Ericsson will not run - HELP!!!  (Read 9138 times)

Offline Tennessee Whiskey

  • Full Member
  • *****
  • Posts: 3773
  • Springfield, Tennessee. USA
Re: Rider Ericsson will not run - HELP!!!
« Reply #30 on: September 11, 2014, 10:43:55 PM »
Thank God Vern, I was bout ready to pack my gear and head your way to help out. Great to see it running and I think we should have a  :DrinkPint: to celebrate. Now bring on the fancy.

Cletus


Offline sshire

  • Full Member
  • *****
  • Posts: 3044
    • LS Editions
Re: Rider Ericsson will not run - HELP!!!
« Reply #31 on: September 11, 2014, 10:54:34 PM »
Cletus
I'm sitting outside, single malt in hand.
I was beginning to think it wouldn't ever run and was ready to show up on Bill's doorstep, engine in hand.
Vern
Best,
Stan

Offline Dave Otto

  • Full Member
  • *****
  • Posts: 3567
  • Boise, Idaho USA
    • Photo Bucket
Re: Rider Ericsson will not run - HELP!!!
« Reply #32 on: September 11, 2014, 11:03:55 PM »
Congrats Stan!

Not very forgiving are they?

There is a fine line on the pump gland between leaking and too tight! I think my buddies engine always seeps a little at the gland, he just mops it up from time to time.

One other observation he has made is the Teflon packing on the piston shrinks over time. He can start out with a new piece and after running a period of time it will have shrunk enough to open the end gap a considerable amount. Doesn't seem to effect the running of the engine though. I told him that it was that cheap Chinese packing that he was using.  :lolb:

Dave

Offline sshire

  • Full Member
  • *****
  • Posts: 3044
    • LS Editions
Re: Rider Ericsson will not run - HELP!!!
« Reply #33 on: September 11, 2014, 11:06:49 PM »
It seems that all Lowes or Home Depot has is cheap Chinese packing. It is interesting that it shrinks. Ian has commented that it expands. Go figure.
Best,
Stan

Offline Kim

  • Global Moderator
  • Full Member
  • *****
  • Posts: 3579
  • Portland, Oregon, USA
Re: Rider Ericsson will not run - HELP!!!
« Reply #34 on: September 11, 2014, 11:16:21 PM »
Congratulations Stan!  That is cool!  I'll bet you're feeling pretty good about that :)

Congrats on getting that stubborn beast to run!
Kim
« Last Edit: September 12, 2014, 02:10:16 AM by krt2 »

Offline sshire

  • Full Member
  • *****
  • Posts: 3044
    • LS Editions
Re: Rider Ericsson will not run - HELP!!!
« Reply #35 on: September 12, 2014, 12:08:34 AM »
I'm guessing they either run out of the box or require much screwing around
Best,
Stan

Offline Don1966

  • Full Member
  • *****
  • Posts: 5982
  • Morgan City, LA (Along the Gulf Coast)
Re: Rider Ericsson will not run - HELP!!!
« Reply #36 on: September 12, 2014, 12:21:23 AM »
Geeee! I knew you would get it solved Stan and congrats buddy.  :ThumbsUp:

Don

Online b.lindsey

  • Global Moderator
  • Full Member
  • *****
  • Posts: 13473
  • Dallas, NC, USA
    • Workbench-Miniatures
Re: Rider Ericsson will not run - HELP!!!
« Reply #37 on: September 12, 2014, 12:25:46 AM »
In addition to my PM let me congratulate you publically on a fine runner. You did a much better job on your build log and that will be a nice resource for future builders. My experience on the cheap Teflon packing is that it shrinks and must be replaced over time. One of these days I will make a Teflon ring for it and be done with it.

Job well done my friend!!!

Bill
« Last Edit: September 12, 2014, 11:36:21 AM by b.lindsey »

Offline 90LX_Notch

  • Full Member
  • ****
  • Posts: 1403
  • North Eastern Pennsylvania USA
    • YouTube Channel
Re: Rider Ericsson will not run - HELP!!!
« Reply #38 on: September 12, 2014, 12:27:15 AM »
Conratulations Stan.  Way to stay with it and get it running.

-Bob
Proud Member of MEM

My Engine Videos on YouTube-
http://www.youtube.com/user/Notch90usa/videos

Offline sshire

  • Full Member
  • *****
  • Posts: 3044
    • LS Editions
Re: Rider Ericsson will not run - HELP!!!
« Reply #39 on: September 12, 2014, 12:43:35 AM »
Thanks for the kind comments. I'm more relieved than anything. There was no chance of giving up after more than three months on this build. Nearly every day. I was just hoping that it wouldn't be a life's work to make it run.
Best,
Stan

Offline philjoe5

  • Full Member
  • ****
  • Posts: 1011
Re: Rider Ericsson will not run - HELP!!!
« Reply #40 on: September 12, 2014, 12:46:24 AM »
Nice work Stan.  After all your fine efforts I knew you'd get her running :ThumbsUp:

Cheers,
Phil
If you pick up a starving dog and make him prosperous, he will not bite you. This is the principal difference between a dog and a man.  - Mark Twain

Offline tvoght

  • Full Member
  • ****
  • Posts: 921
  • Indiana
Re: Rider Ericsson will not run - HELP!!!
« Reply #41 on: September 12, 2014, 12:49:50 AM »
Great news! Great fun to watch running.

--TIm

Offline vcutajar

  • Full Member
  • ****
  • Posts: 2466
  • Marsascala, MALTA
Re: Rider Ericsson will not run - HELP!!!
« Reply #42 on: September 12, 2014, 02:22:18 AM »
Nice work Stan.

Vince

Offline Maryak

  • Global Moderator
  • Full Member
  • *****
  • Posts: 1818
  • Aldinga Beach South Australia
Re: Rider Ericsson will not run - HELP!!!
« Reply #43 on: September 12, 2014, 02:39:51 AM »
Congratulations Stan,

Reminds me of that old saying 10% inspiration 90% perspiration.

Best Regards
Bob
Если вы у Тетушки были яйца, она была бы Дядюшкой

Offline sshire

  • Full Member
  • *****
  • Posts: 3044
    • LS Editions
Re: Rider Ericsson will not run - HELP!!!
« Reply #44 on: September 12, 2014, 02:58:01 AM »
90% aggravation
Best,
Stan