Author Topic: ML7 owners please read and check  (Read 2144 times)

fcheslop

  • Guest
ML7 owners please read and check
« on: May 27, 2014, 04:36:50 PM »
Please check the stop/start as fitted by Myford on later machines.
I have had a little accident this afternoon nothing serious fortunately but it may have been
When measuring a part the lathe suddenly started buzzing and restarted.Pushed the stop and again restarted
On opening the stop/start unit the normally open tip had come out of its housing and was shorting out across the uninsulated spades connectors.
I have replaced the spades with insulated type and refitted the tip locking it in with some silicone adhesive.
When the tip was refitted no way could I get it to come back out so it may have been incorrectly fitted at the factory or due to vibration worked its way out.
I dont wish to appear alarmist and know I should have also used the E/stop button but familiarity breads complacency and this should never have happened .
kind regards
frazer

Offline Jo

  • Administrator
  • Full Member
  • *****
  • Posts: 12712
  • Hampshire, england.
Re: ML7 owners please read and check
« Reply #1 on: May 27, 2014, 05:46:44 PM »
Thanks Frazer  :ThumbsUp: don't like the look of any of those uninsulated spades.

I am trying to work out which connectors those are on the contactor. Are they the over current trip?

Jo

Usus est optimum magister

fcheslop

  • Guest
Re: ML7 owners please read and check
« Reply #2 on: May 27, 2014, 06:36:38 PM »
Hi Jo. The contacts are for the start button and as you can see it had slipped out and shorted out the start connection :censored: